Cisco katsetused

Allikas: Kuutõrvaja

Sissejuhatus

Eesmärgiks on antud juhul üks väike cisco ruuter seadistada NAT ja DHCP teenuseid pakkuma.

Näites on kasutatud cisco 1600 seeria ruuterit. Millel on 2 etherneti porti ning üks konsool. Meie ülesandeks ehitada ruuter kahe võrgu vahele ideaalne.

Picture 007.jpg

Picture 008.jpg

Serial terminal

Käsureale ligi saab näiteks FreeBSD käsureal käsuga kui serial kaabel ühendatud cisco ja arvuti com pordi vahel

# cu -l /dev/cuad0

Või kui cuad0 seadet pole vaid cuau0 siis

# cu -l /dev/cuau0 -s 9600

Windowsis võib kasutada lihtsalt tera termi http://hp.vector.co.jp/authors/VA002416/teraterm.html

Ruuteri vana seadistuse kustutamine ja uue põhja loomine

Kui ruuterit vanrem kasutatud ja sooviks alustada värskelt puhtalt põhjalt.

# enable 

# erase startup-config 

# reload 

Peale seda masin stardib. Ja järgmisena tuleb basic konf initsialiseerida. Küsitakse mitmeid küsimusi routeri hostname admin ja kasutaja parooli kohta SNMP ning võrgu seadistusest.

Minul peale seda tekkis järgnev seadistus:

hostname Router
enable secret 5 $1$VCFk$7345345kkqn93459xy./
enable password parool
line vty 0 4
password parool
snmp-server community public
!
no ip routing

!
interface Ethernet0
shutdown
no ip address
!
interface Ethernet1
shutdown
no ip address
!
interface Serial0
no shutdown
no ip address
!
end

Seadistusmodesse minekuks tuleb trükkida

$ config t

Selles modes saab palju huvitavat teha näiteks keelame ligpääsu kahele ip'le

ciscorouter# conf t
ciscorouter(config)# no access-list 150 deny ip host 10.1.2.1 host 10.3.2.5

Kui seadistusega lõpetanud siis permanentseks konfifaili kirjutamiseks on käsk.

ciscorouter# wr mem
  Building configuration...
Cryptochecksum: 3af43873 d35d6f06 51f8c999 180c2342 
[OK]

Ilma selleta kaob peale rebooti meie vaevaga loodud seadistus

Seadistame võrgu ja NAT'i

Meil on antud väline staatiline ip 84.50.68.182 maskiga 255.255.255.252 ning gateway 84.50.68.181

Skeem kuidas võrk näeb välja oleks selline

C1600.JPG

Seadistame Ethernet0'i mis ühendatud DSL ruuteriga

router(config)#interface Ethernet0
router(config-if)#ip address '84.50.68.182 255.255.255.252
router(config-if)#description v2liv2rk
router(config-if)#ip nat outside
router(config-if)#no shut

ja sisemine liidese Ethernet1'e ip'ga 192.168.1.1

router(config-if)#interface Ethernet1
router(config-if)#ip address 192.168.1.1 255.255.255.0
router(config-if)#ip nat inside
router(config-if)#no shut

Seadistame paika ruutimised

router(config-if)#ip nat inside source list 1 interface ethernet0 overload
router(config)#ip classless
router(config)#ip route 0.0.0.0 0.0.0.0 84.50.68.181
router(config)#access-list 1 permit 192.168.1.0 0.0.0.255
router(config)#ip routing

Olleks interface seadistamise juures saab lisada igale ka kommentaare ja selgitusi

description see on interneti port!

Vaatame ip seadistust

Router#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0              84.50.68.182    YES manual up                    up
Ethernet1              192.168.1.1     YES manual up                    up
Serial0                unassigned      YES unset  down                  down

Ja vaatame nat'i tööd

router#debug ip nat detailed
IP NAT detailed debugging is on
 
00:33:41: NAT: o: udp (193.40.0.225, 137) -> (193.40.0.255, 137) [23558]
00:33:42: NAT: o: udp (193.40.0.225, 137) -> (193.40.0.255, 137) [23563]
00:33:42: NAT*: i: icmp (192.168.1.10, 64274) -> (194.126.101.79, 64274) [0]
00:33:42: NAT*: o: icmp (194.126.101.79, 64274) -> (193.40.0.182, 64274) [3259]
00:33:42: NAT: i: udp (84.50.68.182, 32773) -> (193.40.0.12, 53) [60699]
00:33:42: NAT: o: udp (193.40.0.12, 53) -> (193.40.0.10, 32773) [53254]


Hetkel töötava serveri seadistuse saame käsuga

# show running-config
Building configuration... 

Current configuration:
!
version 12.0
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
enable secret 5 $1$UL/2$QVKigr3d5jmWcJ/.XS.JG0
enable password parool
!
ip subnet-zero
!
!
!
interface Ethernet0
 description v2liv2rk
 ip address 84.50.68.182 255.255.255.252
 no ip directed-broadcast
 ip nat outside
 no cdp enable
!
interface Ethernet1
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside
 no cdp enable
!
 interface Serial0
 no ip address
 no ip directed-broadcast
 no fair-queue
!
ip nat inside source list 1 interface Ethernet0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 84.50.68.181
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
line con 0
 exec-timeout 0 0
 transport input none
line vty 0 4
 password parool
 login
!
end

Kirjutame käsu wr mem ,et salvestada muudatused ning ruuter on seadistatud.

Konfiguratsioonist puhta seadme salvestamiseks tuleb lihtsal

# configure terminal

Ja kopeeri konfiguratsioon

Ning salvestame seadistuse

Pordi suunamine

Pordi suunamisse näide. Suuname 22 pordi liideselt FastEthernet0/0 ip'le 192.168.1.5 pordile 22

ip nat inside source static tcp 192.168.1.5 22 interface FastEthernet0/0 22


Cisco switchil management IP seadistamine

Meil olukord, kus soovime seadistada hallatavale cisco switchile lihtsalt manageerimise aadressi.

Aadressi võiks seadistada Vlan1 nimelisele interfacele

Juhul, kui ruuting ei ole switchil sisse lülitatud, siis käib vaikeruutingu seadistamine nii:

ip default-gateway 193.40.55.1

Universaalsuse mõttes võib muidugi ip ruutingu sisse lülitada käsuga

ip routing 

Lingid

Cisco IOS on väga võimalusterohke operatsioonisüsteem. Sellekohta on cisco andnud välja väga ohtralt ametlikku materjali. Neid siin äratooma ei hakka pigem mõned alternatiivsed viited.

http://www.pimpmynetwork.org/basic_cisco

http://www.fantek.org/cisco/wpbascom.htm

http://www.velocityreviews.com/forums/t41103-basic-cisco-switch-tutorial.html

http://geek.pandemonium.de/2005/07/09/dhcp-server-on-a-cisco-1605/

http://www.cisco.com/warp/public/109/config_nat_on_cm.html

http://www.tomax7.com/mcse/cisco_routerconfig.htm

http://www.linuxhomenetworking.com/cisco-hn/dsl-router.htm

http://www.opalsoft.net/qos/WhyQos-2422.htm

http://www.cisco.com/en/US/docs/ios/12_0/qos/configuration/guide/qcpolts.html

http://www.intelligentedu.com/links/free_cisco_documentation.html

http://www.cisco.com/warp/public/105/policevsshape.html

http://www.swcp.com/~jgentry/topo/cisco.htm

http://www.cisco.com/warp/public/701/3.html

http://www.cisco.com/en/US/docs/routers/access/800/820/software/configuration/guide/routconf.html

http://www.mavetju.org/networking/security.php

http://www.parkansky.com/tutorials/dmz.htm

http://ciscotips.wordpress.com/

http://www.oreillynet.com/pub/a/network/2002/01/02/ciscotips.html kasulikud nipid cisco kasutamisel

http://www.cisco.com/en/US/docs/ios/12_1/configfun/command/reference/frd1001.html